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What’s New in Maptitude 2023 
 

Maptitude 2023: New Features Overview 

Maptitude 2023 is a major release of Caliper Corporation’s popular Geographic Information 
System (GIS) and mapping software. The 2023 version provides the most up-to-date and accurate 
data available. 

Maptitude 2023 provides the business value you expect when investing in mapping software. 
Maptitude includes the latest streets, postal data, and demographics. Maptitude 2023 is the 
fastest and most intuitive professional mapping application, with significant enhancements to 
sharing, visualizations, and logistics/operations analytics. 

Key Features of Maptitude 2023 
1. Sales territory map editing is now faster. It is also much easier to switch between multiple 

territory layers in a map using the redesigned Territory Manager. When using selection sets to 
manage your alignments, you can now track multiple running total columns. 

2. The most up-to-date geographic and demographic information available, including the latest 
data and boundaries from the American Community Survey (ACS) and 2020 USA Census. 

3. Maptitude Online allows you to easily share your desktop Maptitude data privately with your 
team or publicly as a web app. Map background tiles are now provided for Germany, Austria, 
Switzerland, France, Italy, and Portugal in addition to the UK, Ireland, Canada, Australia, New 
Zealand, and the USA. Shared maps can also be embedded on your website as an iframe. 

4. Maptitude Online as a stand-alone SaaS application allows you to map your data using any 
device or operating system. New features allow you to select and filter map features and 
dataviews, to delete map layers, to add multiple spreadsheets of data to a map, and to add 
new thematics and analytics to an existing map using the Create-a-map-Wizard and sets. 

5. Maptitude continues to expand support for MapPoint users with the ability to import pushpin 
information labels and to import read-only drawing items. 

6. The enhancements to the Routing Deliveries & Pickups tool provide powerful new logistics 
features for optimizing your delivery fleets. You can model multiple vehicles, routes, and 
depots, over multiple days, with rest stops, time windows, and balancing. In addition, routing 
calculations are now faster. 

7. A variety of new and improved visualizations have been implemented that include a scatter plot 
chart and large area hot-spot thematic maps.  

8. Interoperability with external data has been expanded with support for OpenStreetMap point 
and area layers, in addition to lines. 

9. The entire interface can be translated into Chinese or Spanish simply by changing a 
preference. The addition of Unicode supports the display of characters and fonts in different 
languages. 
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Maptitude can map your information whether you have data from Google Maps, from a Microsoft 
mapping product such as MapPoint, or from Microsoft Office. You can analyze your information 
using the intuitive Maptitude 2023 mapping wizards and export your results as attractive, 
preformatted Excel or PDF reports, or upload them to Maptitude Online for public or private 
sharing.  

Maptitude delivers easy-to-use professional mapping tools and data at the unbeatable price of 
only US$695 (or US$420 for Maptitude Online.) For pricing and ordering information, please visit 
the Mapping Software Store, e-mail Maptitude Sales, or call US sales at +1 617-527-4700.  

New Data 

Maptitude 2023 comes standard with one detailed Country Package of your choice, and 
additional Country Packages can be purchased separately. Each Country Package includes a 
wealth of data unavailable in any other product, such as an up-to-date street layer with addresses 
for pin-mapping (geocoding) and travel time information for computing routes and drive-time 
rings. Features such as building footprints for many urban locations, railways, and named 
landmarks are also built into the software. The comprehensive landmarks range from public 
facilities to commercial buildings including businesses, restaurants, and retail stores, and include 
addresses and phone numbers where available. Where available, postal data and detailed 
demographics are shipped with the product. 

As you switch between the countries you have purchased, Maptitude will seamlessly refresh the 
interface with country-specific tools such as Create-A-Map Wizard and tools for finding, pin-
mapping, and routing. New Map Libraries allow you to easily create attractive geographic and 
demographic maps while locating unlimited numbers of addresses and territory-based records. 

The basic global map that is provided with every Maptitude license enables you to view your data 
for anywhere on Earth, and it allows you to map your locations by coordinate, manually, or by any 
populated place (village/town/city). 

United States 
New U.S. datasets provide access to the most up-to-date geographic information available. 
Maptitude 2023 comes with October 2022 HERE® Map Content, which allows for accurate address 
locating and street visualization, in addition to robust data that you can use to calculate 
directions, drive-time rings, and drive-time territories. Speeds based on HERE Traffic Patterns are 
included. 

Other 2022 U.S. map layers from HERE include those for buildings, highways, railroads, and 
landmarks. The Points of Interest layer contains over 3.7 million named public and business 
locations. 

Maptitude 2023 ships with the January 2023 ZIP Code update to ensure that you are using the 
latest data. The 5-digit ZIP Code boundaries are a nationwide area database with ZIP Codes for all 
50 states, the District of Columbia, Puerto Rico, and the territories.  

http://www.caliper.com/maptpric.htm
https://www2.caliper.com/store/product-category/software/
mailto:sales@caliper.com
tel:+16175274700
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Other standard features of Maptitude 2023 are updated 3-digit ZIP Code areas and a point 
database of ZIP Code points for the entire country. The ZIP Code area layers extend into non-
deliverable areas to provide complete coverage of the USA. The 3-digit and 5-digit ZIP Code 
areas include updated counts of businesses by detailed industry type (retail, finance, etc.), along 
with the number of employees working in each ZIP Code, and annual payroll figures. The ZIP 
Codes are also classified by their updated rural-urban commuting characteristics and with the 
numbers of hospitals, hospital beds, and healthcare providers. The HERE street layer now 
indicates whether a street permits cars, buses, deliveries, emergency vehicles, motorcycles, 
pedestrians, taxis, through traffic, or trucks. 

The US Census boundaries (e.g., Tracts, Places, Counties, MCDs, MSAs, States) and the 3- and 5-
digit ZIP code areas that come with Maptitude contain some or all of several demographic 
profiles from a variety of data providers. These sources include the 2020 Census and the 2021 
American Community Survey (ACS) to name a few. This data is available for the USA, Puerto Rico, 
and the Territories. These layers include daytime population, and percent change (2020 to 2021) 
in population, median income, and mean income. The ZIP Code, Tract, County, and State layers 
also include updated buying power (disposable income for 2020) figures.  

Personal income and change in personal income BEA data for 2021 are included for States and 
Counties, and 2021 GDP (by total, goods, services, government, and by 2-digit NAICS code) and 
change in GDP BEA data for 2021 are included for Counties. 2025 population projections for 
Counties, States, and Tracts are included by age, race, gender, and ethnicity, and for population 
by 5-year increment for 2025-2100.  

The Demographic Map Librarian tool makes it easy to access a series of pre-defined thematic 
and shaded maps of the updated data. There are also maps for the 2020 Tract layer with updated 
banking compliance FFIEC data for 2022. 

The Country Package updates under development are listed below: 
Australia 
• October 2022 HERE update with speeds based on noontime HERE Traffic Patterns 
• Updated HERE postal boundaries and centroids 
• 2021 Census Demographics 

Brazil 
• October 2022 HERE update with speeds based on noontime HERE Traffic Patterns 
• Updated HERE postal boundaries and centroids 

Canada 
• October 2022 HERE update with speeds based on noontime HERE Traffic Patterns 
• Updated 3-character postal Forward Sortation Area (FSA) boundaries and centroids (HERE) 
• Updated 6-character postal point layer (HERE) 
• New 6-character postal area layer (Caliper Created/Derived from HERE) 
• 2022 Population estimates for Provinces 
• 2021 Census Demographics 

http://www.caliper.com/maptitude/international/unitedstates.htm
http://www.caliper.com/maptitude/international/unitedstates.htm
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United Kingdom 
• October 2022 HERE update with speeds based on noontime HERE Traffic Patterns 
• Updated postal boundaries for the UK (HERE) 
• Updated postal boundaries and postcode points for GB (Caliper)  
• 2021 Estimated population by age and gender, UK 
• 2021 Census Demographics 

Mexico 
• October 2022 HERE update with speeds based on noontime HERE Traffic Patterns 
• Updated HERE postal boundaries and centroids 

New Zealand 
• October 2022 HERE update with speeds based on noontime HERE Traffic Patterns 
• Updated HERE postal boundaries and centroids 

Network Analysis, Directions, and Routing 

Maptitude 2023 gives you powerful tools to model routes, to calculate the distances and travel 
times between locations, and to display and analyze service provision over the road network. 

Routing & Directions Manager 
The Tools>Routing & Directions> 
Routing & Directions Manager now: 

• Saves your settings with your 
workspace (*.WRKZ), no longer 
requiring separate files to 
save/open 

 
 
 
Routing Deliveries and Pickups (2023 Beta) 

The Tools>GISDK Developer's Kit>Add-Ins>Vehicle Routing and Deliveries tool now: 

• Supports, for vehicles, global settings for driving start and end times 
• Supports, for vehicles, global settings for rests and breaks based on route or driving time and 

with a time flexibility threshold 
• Uses pre-processing and multiple threads for faster calculations 
• Better optimizes routes 
• Better handling of multiple time windows 
• Supports route balancing across depots using time, distance, or number of stops and with a 

time flexibility threshold 
• Allows depots to have multiple vehicle types, where there can be multiples of each vehicle type 
• Allows vehicles to service multiple routes during a single time frame, which is useful for 

vehicles that have to return to the depot due to factors such as limited capacities, short trips, 
but with heavy demand 

• Supports schedules that span multiple days 
• Allows vehicles to make multiple routes for multiple day schedules 
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New Map Styles 

Maptitude 2023 gives you the greatest flexibility to date in setting the styles of map features, 
themes, and selection sets. 

Themes 
• The Map>Display Manager Toolbar now: 

o Allows you to show or hide a theme by toggling visibility using the green check/red cross 
buttons, giving you the ability to easily switch between different thematic visualizations 

Labels 
• Labels now: 

o  
o Support the display of Emojis when 

using the Segoe UI Emoji font 
o Support Unicode that allows, for 

example, the display of characters 
from different languages at the same 
time 

Drawing 
• Drawing items now: 

o Support the display of Emojis when 
using the Segoe UI Emoji font 

o Support Unicode that allows, for 
example, the display of characters 
from different languages at the same 
time 

New Database Functionality 

New capabilities for geographic databases have been introduced. 

• Supports the display of Emojis when using the Segoe UI Emoji font 
• Supports Unicode that allows, for example, the display of characters from different languages 

at the same time 
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Locating Data 

The geocoding tools use the updated street and postal data, making location matching results 
more accurate than in previous versions of Maptitude. 

• The Tools>Locate>Locate by Value method provides faster geocoding 
• The Global Geocoding and Download Free Layers Add-In now: 

o Correctly displays Unicode characters from different languages in the downloaded 
data 

Improved Create-a-Map Wizard 

Create-a-Map Wizard is now more 
robust and easier to use: 

• The maps have been updated 
with the latest geography 

• The Wizard help panel has been 
updated to better scale images 
on high resolution 4K monitors 

• Create separate and/or 
cumulative buffers/radii using 
the Create-a-Map-Wizard, 
allowing for demographic 
reports for each location 

Creating Selections and Formulas 

Condition building tools improvements: 

• The Selection>Toolbar> 
Options under “Optional Tools” 
allows for showing multiple 
running total fields, making it 
easier to see data on-the-fly as 
you select records 

• The Selection>Settings>Style 
under “Options” allows for 
Show Centroids by selection 
set, making it possible to 
visualize area layer sets using 
icon styles 

• The dataview right-click Delete 
Formula Field(s) context 
sensitive menu allows you to 
remove expression columns 
without having to use the 
Formula Fields dialog box  

https://www.caliper.com/maptitude/gisdk/free-batch-geocoding.htm
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Analysis Tools 

Completely new and innovative analytics have been added to Maptitude 2023: 

• The Map>Territory Manager Toolbar: 
o Provides a grid view that allows for resizing of columns  
o Supports toggling of the tool from the menu, the close button, and from the Territory 

Manager Toolbar button, making it easier to switch between territories in a map 
o Supports faster territory map editing  

 

• The Tools>Analysis>Density/Heat Layer tool: 
o Supports analysis over much larger areas and can be used to visualize densities at the 

continental and global scale 
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Output Improvements 

In Maptitude 2023: 

• Added Scatter Plots chart type 
o The Dataview>Statistics>Scatter Plots chart allows you to visualize and test the 

strength of the relationship between two attributes along with the equation of the 
trendline and the regression constant 

 
• Added a customizable font setting to Tools>Reports>Settings>Report Settings 

Imagery Improvements 

Accessing, creating, and visualizing imagery is a core feature of Maptitude:  

• File>Export>Image now defaults to the Portable Network Graphic file format instead of 
Windows Bitmap, encouraging smaller file sizes without a loss of resolution 

New Documentation 

Maptitude continues to provide numerous ways to get you started with the software. The online 
Learning Portal has been updated, and new and revised tutorials are incorporated into the 
Maptitude Help.  

In addition, a variety of comprehensive learning materials (including videos and live or pre-
recorded training webinars) are available on the Caliper Corporation website. The training videos 
run in all browsers, with playback settings, as Vimeo and YouTube videos. 

The Maptitude Help (Help>Maptitude Help) can be viewed within a web browser and has a 
modern browser-based interface. The GISDK Help (Help>GISDK Help) is available online. 

Maptitude 2023 includes a Windows Microsoft Office style question mark icon on most windows. 
Clicking this will take you to the relevant section of the Help. You can also hover over any menu 
item and click F1 to access the updated Help. In addition, several message windows in Maptitude 
link directly to the relevant Learning Portal article. 

https://www.caliper.com/learning/
https://www.caliper.com/learning/
https://www.caliper.com/maptitude/mapping-software-video-tutorials.htm
https://www.caliper.com/learning/gis-development-kit/#t=dk%2FIDH_CONTENTS.htm
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System and Interface 

Maptitude 2023 supports the latest Windows operating systems, file types, and common design 
elements.  

• The Edit>Preferences>System>Language>Translate Interface option now supports full 
interface translation into Spanish or Chinese (Simplified). 

• The support for Maptitude on Intel chip Apple Macs with Windows has been extended to 
Apple Mac or Surface Pro ARM M1/M2 chips with Windows. Please contact Sales for the ARM 
enabled version. 

• The Maptitude installer remembers your previously entered serial number. 
• The Maptitude buttons are now displayed in a modern flat style. 
• The File Not Found window file path can be visualized as a tooltip and copied via a new 

button.  
• The support for 4K high resolution monitors has been improved with scaling of Wizard 

images, toolbar titles, and buttons. 
• The Map>Territory Manager Toolbar>Select by Condition button has moved to the 

selection toolstrip, an Add New Territory button was implemented, and drop-down list 
prompt wording is improved in the territory tools. 

• The support for Unicode has been implemented and the Edit>Preferences>System options 
for Code Page and Locale are used when converting strings in workspaces and tables to  
UTF-8. 

New File Import Support 
• MapPoint (*.AXE; *.EST; *.PTM) pushpin information labels and read-only drawing items 
• OpenStreetMap (*.OSM) batch import point and area layers (in addition to lines) 
• OpenStreetMap (*.OSM) optionally intersect all lines for Highway layers 
• GeoJson (*.GEOJSON; *.JSON) optional import in Open File window 
• ESRI File Geodatabase (*.GDB) optional import in Open File window 
• ESRI File Geodatabase (*.GDB) optional linking of line and node layers 

New File Export Support 
• Microsoft Excel (*.XLSX) support for date and time field types 

New Native File Support 
• GeoJson (*.GEOJSON; *.JSON) optional “Add to map” in File Open window 

mailto:sales@caliper.com?subject=Maptitude%20for%20MAC%20or%20Surface%20Pro%20ARM%20Chips
mailto:sales@caliper.com?subject=Maptitude%20for%20MAC%20or%20Surface%20Pro%20ARM%20Chips
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Maptitude Online 

Maptitude Online is both a map sharing add-in for desktop Maptitude and a stand-alone 
mapping application. New capabilities are listed below. 

Online Sharing 
As a sharing add-in, maps and reports are created and uploaded using desktop Maptitude. Once 
uploaded, you can use the maps with the full functionality of the SaaS. 

• Upload your maps when you have a Country Package for Germany, Austria, Switzerland, 
France, Italy, or Portugal in addition to the UK, Ireland, Canada, Australia, New Zealand, and 
the USA 

 
• Embed publicly shared maps on your website as an iframe 

Software-as-a-Service (SaaS) 
Desktop Maptitude is not required to use Maptitude Online. Directly from your browser you can 
upload Excel or CSV tables and map the data using the Create-a-Map-Wizard. The maps can be 
shared online publicly or privately. 

• Select point, line, and area map features interactively and by query/condition 

 

https://www.caliper.com/maptitude/online-mapping-software-web-mapping-online-gis.htm#desktop
https://www.caliper.com/maptitude/online-mapping-software-web-mapping-online-gis.htm#app
https://www.caliper.com/maptitude/online-mapping-software-web-mapping-online-gis.htm#app
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• Map all or selected features with the Create-a-Map-Wizard  
• Filter dataviews using selected features 
• Delete map layers from a map 
• Add more than one spreadsheet/table of data to a map using the Create-a-Map-Wizard 
• Add or replace a layer theme (color/chart/size/symbol) using the Create-a-Map-Wizard 
• Add or replace an analysis layer (buffer/weighted center/areas of influence) using the Create-

a-Map-Wizard 
• Add or change layer labels using the Create-a-Map-Wizard 
• Toggle the selection set style visibility for area layers 
• Create multiple selections on a layer, allowing, for example, interactive creation and 

visualization of territories (as sets) on an area layer such as ZIP Codes, Counties, or States 
• Create separate and/or cumulative buffers/radii using the Create-a-Map-Wizard, allowing for 

demographic reports for each location 

Geographic Information System Developer’s Kit (GISDK) 

APIs 
The GISDK APIs make it easy to add mapping functionality to any Windows desktop application 
written in Python, C#, or any .NET programming language. 

Code examples and the user documentation for the Maptitude API have been updated for 
Maptitude 2023 and are included under Help>GISDK Help.  

The following functions and code have been added or modified: 

• Routing.Router DisplayPath() now uses with AddAnnotation() the "Path" type instead of 
"Polyline" to support the display of longer routes 

• “GISDK Snippets” is a Microsoft Visual Studio Code snippets extension that makes it easier to 
develop with Caliper Script. 

• A new VBA example, a new VB.NET example, and individual folders for the GISDK, DotNet, 
Python, VB, and VBA examples have been added to the Maptitude samples folder. 

GISDK Functions 
Please see the “Listing of GISDK Functions” topic in the Online Help to view a full list of GISDK 
functions that were added, changed, or replaced in Maptitude 2023. Highlights of the GISDK 
changes: 

• ReplaceArea() supports the modification of non-topological area layers, e.g., territories, and is 
used instead of the much slower AddToArea() and RemoveFromArea() 

• Compound datetime variables now support a "delta" method for days, hours, minutes, 
seconds, and milliseconds: DaysSince, HoursSince, MinutesSince, SecondSince, 
MillisecondsSince 

• Unhandled error messages now contain the exception name (notfound, error, etc.) 
• GISDK Debugger: shows line numbers in the editor window; supports context sensitive “run 

to” and “jump to” menus; supports shortcut keys for “run to” (Ctrl-F10) and “jump to” (Ctrl-
Shift-F10); supports context sensitive menus for the alphabetical sorting of variables and 
watch expressions 

http://www.mappingsoftware.com/
https://www.caliper.com/maptitude/gis-software/default.htm
https://www.caliper.com/maptitude/mapping-software.htm
https://www.caliper.com/maptitude/mapping-software.htm
https://www.caliper.com/mapsoftware.htm
https://www.caliper.com/redistricting-software.htm
http://www.caliper.com/tcovu.htm
https://www.caliper.com/transmodeler/default.htm
https://www.caliper.com/maptitude/gis-software/default.htm
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About Caliper  

Caliper Corporation develops state-of-the-art Geographic Information System (GIS) software. 
With a focus on usability, Maptitude is designed to be the most cost-effective 
professional mapping software product on the market. Maptitude enables organizations to 
leverage their location-based data to improve decision making and planning while minimizing 
expenditure through competitively priced solutions. 

Caliper is a privately held corporation and is a leading developer of mapping, 
redistricting, transportation, traffic simulation, and GIS software. 

http://www.mappingsoftware.com/
https://www.caliper.com/maptitude/gis-software/default.htm
https://www.caliper.com/maptitude/mapping-software.htm
https://www.caliper.com/maptitude/mapping-software.htm
https://www.caliper.com/mapsoftware.htm
https://www.caliper.com/redistricting-software.htm
http://www.caliper.com/tcovu.htm
https://www.caliper.com/transmodeler/default.htm
https://www.caliper.com/maptitude/gis-software/default.htm



