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What’s New in Maptitude 2019 
 

Maptitude 2019: New Features Overview 
Maptitude 2019 is a major release of Caliper Corporation’s popular Geographic Information System (GIS) 
and mapping software. The 2019 version provides the most up-to-date and accurate data available. 

Maptitude 2019 provides the business value you expect when investing in mapping software. Maptitude 
includes the latest streets, postal data, and demographics. Maptitude 2019 is the fastest and most 
intuitive professional mapping application, with significant enhancements to usability, data 
import/linking, and information sharing. 

Key Features of Maptitude 2019: 
1. The most up-to-date geographic and demographic information available, including address and 

phone number for points-of-interest/landmarks, and new data describing personal income, 
number of unique households, and Gross Domestic Product (or “GDP”, the value of all goods and 
services produced in an area) 

2. The geocoder successfully pin-maps even more address and postal data 
3. For area layers (such as postal boundaries) and points geocoded by coordinate (e.g., 

longitude/latitude) the ability to link your map to external data and update your map without 
having to reimport your table from scratch 

4. An improved Activation Wizard that is easier-to-use and reduces reactivation requests 
5. Support for discontinued Microsoft MapPoint and Streets & Trips (.PTM, .EST, .AXE) files makes 

Maptitude the obvious replacement, and Maptitude 2019 imports waypoints directly into the 
Routing Manager, and supports MapPoint shapes/lines/text and the ability to edit them 

6. Create travel time or distance tables that identify the closest locations (e.g., the ten closest 
customers to a store) using either straight-line or road-based calculations 

7. The Export to Excel reports can be customized, allowing you to choose which calculations (drive-
time, distance, overlay), layers, map features, and demographics are included 

8. The Maptitude Help has been redesigned to be viewed within a web browser and a Learning Portal 
has been added to the website 

9. The map background imagery layers draw faster and with better resolution  
10. Workspaces support auto-saving (in case you lose your work or forget to save it), file-locking 

(preventing accidental file overwriting), and can compress all your windows and tables and map 
layers into a single file for sharing 

Maptitude can map your information whether you have data from Google Maps, from a Microsoft 
mapping product such as MapPoint, or from Microsoft Office. You can analyze your information using the 
intuitive Maptitude 2019 mapping wizards and export your results as attractive, preformatted Excel or 
PDF reports.  

Maptitude delivers easy-to-use professional mapping tools and data at the unbeatable price of only 
US$695 (or US$395 for upgrades.) For pricing and ordering information, please visit the Mapping 
Software Store, e-mail Maptitude Sales, or call US sales at +1 617-527-4700.  

http://www.caliper.com/maptpric.htm
https://www2.caliper.com/store/product-category/software/
https://www2.caliper.com/store/product-category/software/
mailto:sales@caliper.com
tel:+16175274700
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New Data 
Country Packages 
Maptitude 2019 comes standard with one detailed Country Package of your choice, and additional 
Country Packages can be purchased separately. Each Country Package includes a wealth of data 
unavailable in any other product, such as an up-to-date street layer with addresses for pin-mapping 
(geocoding) and travel time information for computing routes and drive-time rings. Features such as 
building footprints for many urban locations, railways, and named landmarks are also built in to the 
software. The comprehensive landmarks range from public facilities to commercial buildings including 
businesses, restaurants, and retail stores, and now include addresses and phone numbers where 
available. Where available, postal data and detailed demographics are shipped with the product. 

As you switch between the countries you have purchased, Maptitude will seamlessly refresh the interface 
with country-specific tools such as Create-A-Map Wizard and tools for finding, pin-mapping, and routing. 
New Map Libraries allow you to easily create attractive geographic and demographic maps while locating 
unlimited numbers of addresses and territory-based records. 

The basic global map that is provided with every Maptitude license enables you to view your data for 
anywhere on Earth, and it allows you to map your locations by coordinate, manually, or by any populated 
place (village/town/city). 

United States 
New U.S. datasets provide access to the most up-
to-date geographic information available. 
Maptitude 2019 comes with October 2018 HERE® 
Map Content, which allows for accurate address 
locating and street visualization, in addition to 
robust data with which you can calculate shortest 
paths, drive-time rings, and drive-time territories 
(network partitions). Speeds based on HERE 
Traffic Patterns are now included. 

Other 2018 U.S. map layers from HERE include 
those for buildings, highways, railroads, and 
landmarks. The Points of Interest layer contains 
over two million named public and business 
locations. 

Maptitude 2019 ships with the January 2019 ZIP 
Code update to ensure that you are using the 
latest data. The 5-digit ZIP Code boundaries are a 
nationwide area database with ZIP Codes for all 
50 states, the District of Columbia, Puerto Rico, 
and the territories.  

Includes October 2018 map layers from HERE 

 

Includes GDP data (goods, services, government, and total) by 
county 
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Other standard features of Maptitude 2019 are updated 3-digit ZIP Code areas and a point database of 
ZIP Code centroids for the entire country. The ZIP Code area layers extend into non-deliverable areas to 
provide complete coverage of the USA. The 3-digit and 5-digit ZIP Code areas include updated counts of 
businesses by detailed industry type (retail, finance, etc.), along with the number of employees working in 
each ZIP Code, and annual payroll figures. The ZIP Codes are also classified by their updated rural-urban 
commuting characteristics and with the numbers of hospitals, hospital beds, and healthcare providers.  

The US Census boundaries (e.g., Tracts, Counties, MCDs, MSAs, States) and the 3- and 5-digit ZIP code 
areas that come with Maptitude contain some or all of several demographic profiles from a variety of 
data providers. These sources include the 2010 Census and the 2017 American Community Survey (ACS) 
to name a few. The data are available for the USA, Puerto Rico, and the Territories and include fields such 
as daytime population, percent change (2016 to 2017) in population, median income, and mean income, 
and now include unique households by household size fields based on the 2017 ACS. The ZIP Code, 
Tract, County, and State layers also include updated buying power (disposable income for 2016) figures. 
Tracts also list updated banking compliance FFIEC data for 2018. Personal income and change in personal 
income BEA data for 2017 are now included for States and Counties, and GDP (total, goods, services, 
government) and change in GDP BEA data for 2015 are now included for Counties. The Map Librarian 
makes it easy to access a series of pre-defined thematic and shaded maps of these updated data. 

The metropolitan area map layers (MSA/CBSA, CSA and CBSA Division) have been updated. 

The Country Package updates under development are listed below: 

Australia 
• October 2018 HERE update with speeds based on noontime HERE® Traffic Patterns 
• Updated HERE postal boundaries and centroids 

Brazil 
• October 2018 HERE update with speeds based on noontime HERE® Traffic Patterns 
• Updated HERE postal point layer 

Canada 
• October 2018 HERE update with speeds based on noontime HERE® Traffic Patterns 
• Updated 3-character postal Forward Sortation Area (FSA) boundaries and centroids (HERE) 
• Updated 6- character postal point layer (HERE) 

United Kingdom 
• October 2018 HERE update with speeds based on noontime HERE® Traffic Patterns 
• Updated postal boundaries for the UK (HERE) 
• Updated postal boundaries and postcode points for GB (Caliper)  
• 2017 Estimated population by age and gender, UK 

Mexico 
• October 2018 HERE update with speeds based on noontime HERE® Traffic Patterns 
• Updated HERE postal boundaries and centroids 
• Updated Caliper postal boundaries 

New Zealand 
• October 2018 HERE update with speeds based on noontime HERE® Traffic Patterns 
• Updated HERE postal boundaries and centroids 

http://www.caliper.com/Maptitude/International/unitedstates.htm
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Network Analysis and Routing 
Routing & Directions Manager 
The Routing & Directions Manager now: 

• Allows repeated consecutive stops, e.g., multiple destinations in a 
rental building 

• Launches pre-populated with imported MapPoint route data 
• Supports overnight routing schedules 
• Allows for longer route names 
• Applies Automatic Rest restrictions to the total route time and not 

just driving time 
• Imports waypoint specific “arrive” and “depart” times from files 

such as Excel and MapPoint 

Drive-Time Rings Toolbar 
The Drive Time Rings Toolbar creates the most accurate drive-distance travel analysis on the market with 
the following enhancements to the tool: 

• Allows waypoints/origins to be placed anywhere along a road line 
• Supports up to 1000 concentric rings 
• Supports an unlimited number of waypoints/origins 
• Creates separate rings in a shorter amount of time 

Distance and Travel Time Tables Tool 
Maptitude 2019 makes it easy to identify alternative service suppliers, backup field representatives, and 
closest locations. The distance and drive-time tool creates an Excel table that lists the costs of travel 
between any number of origins and destinations, allowing you to easily sort the data to identify the 
closest locations. 

The Distance and Travel Time Tables Tool now: 

• Optionally lists those destinations that cannot be reached within the time or distance chosen, 
allowing you to identify those locations that are not served 

• Optionally restricts the analysis to the specified number of closest locations, e.g., the ten closest 
customers to a store 

• Supports straight line distance calculations that enable faster, and a greater number of, origin-to-
destination calculations  

• Provides results in a shorter amount of time 
• Calculates area-to-area routes when the area centroid is up to 16 miles from a road, e.g., when 

calculating travel costs between postal areas in rural or lightly populated areas 
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New Map Styles 
Maptitude 2019 gives you the greatest flexibility to date in setting the styles of map features, themes, and 
selection sets. 

Styles 
• The centroid point of area layers can be 

shown and customized 
• The default color images for point layer styles 

lists 395 new icons and support creation of 
firefly cartography (or glow-maps) 

Layers 
• The 2019 Country Package maps display more 

point-of-interest icons and categories, 
allowing you to differentiate sub-types of 
restaurants and retail locations 

Themes 
• The Color Theme defaults under Edit > 

Preferences > Theme, ensure that user data is 
prominently displayed on a map 

• The 3-D Themes Window supports a color 
range legend in addition to the height axis, 
allowing you to compare 2 columns of data 

Labels 
• The Hover Labels automatically show any 

columns used when creating a theme, allowing 
you to quickly see the data used in a color 
theme, for example, for each shaded location 

New Database Functionality 
The new capabilities for geographic databases that have been introduced are: 

• Hovering over AREA and LENGTH column names for area and line layers respectively, shows the units 
used, e.g., hovering over the AREA field for the State layer shows “Area of feature in Square Miles” 

• Right-clicking in the Display Manager and choosing New Dataview on a joined view sets the 
dataview highlight to be the user join field 

• Choosing Edit>Preferences>Editing>Linked Records>Allow edits to a Linked Records Dataview 
allows you to edit the tabular data for linked records in situations where you need to perform an 
analysis such as tagging 

• Dropping your layers from a compressed workspace is supported by Undo/Redo 
• Clicking on drawing items such as areas and lines with the pointer tool allows you to edit them 
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Locating Data 
The geocoding tools use the updated street and postal data, making location matching results more 
accurate than in older versions of Maptitude. 

Country Package Specific Changes 
• The Find tool allows you to zoom to the extent of the country/region of the data package you have 

purchased.  
• The geocoding tools provide improved success rates when using a second address field.  

Improved Create-a-Map Wizard 
Create-a-Map Wizard is now more robust and easier to use: 

• The Multiple Symbol Theme is supported for point layers, allowing you to categorize your data by 
icon. 

• The maps have been updated with the latest geography. 
• The Display Manager expands to show any themes that are created via the Wizard or the interface, 

emphasizing your results. 
• The Display Manager expands to show the “My Data” sets that are created via the Wizard when 

choosing to “Show … boundaries with your data attached”, emphasizing your results. 
• The “Link Data” and “Update Linked Records” 

tools support linking to external data for 
area layers (such as postal boundaries) and 
to update the map layer without having to 
reimport the entire table from scratch. 

• The “Link Data” and “Update Linked Records” 
tools support geocoding by coordinate (e.g., 
longitude/latitude). 

• The “Link Data” and “Update Linked Records” 
tools are much more robust. 

Creating Selections and Formulas 
Condition building tools improvements: 

• The menu command Selection>Select by Map Window allows you to select the features visible in 
the map window. 

• The Create New Selection tool now prompts you to choose a selection set name. 
• The Dataview>Formula Fields>Statistics tool allows you to easily calculate statistics for multiple 

fields when creating a formula. 
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Projections/Datums 
Maptitude 2019 has expanded support for datums and projections with: 

• The addition of the OSTN for Great Britain and GDA94/GDA2020 for Australia datum conversions 
• The auto-projection settings for the British Isles use a Mercator projection that ensures that the 

United Kingdom does not appear to be at an angle 

Analysis Tools 
Completely new and innovative analytics were added to Maptitude 2019: 

• The Angle tool  allows you to draw an angle on the screen which then reports the angle at the 

vertex in degrees. 
• The Tools>Analysis>Buffers tool Visible Features option allows you to create radii around the 

locations shown on the map without having to first create a selection set of those locations. 
• The Tools>Analysis>Buffers tool Cumulative Buffers option allows the demographics of 

consecutive rings to be summed cumulatively. 
• The Tools>Analysis>Facility Location tool 

supports straight line distance calculations 
that enable faster, and a greater number of, 
client-to-facility calculations. 

• The Territory Manager toolbar selects 
Census Tracts by a geography such as State 
or County in a shorter amount of time. 

• The Tools>Analysis>Density/Heat Layer 
tool has improved default styles that include 
use of a spectral palette.  

Output Improvements 
In Maptitude 2019: 

• The Edit>Preferences>Reporting>Export to Excel Settings allows you to modify the Excel reports 
by choosing which calculations (drive-time, distance, overlay), layers, and map features are included. 

• The Edit>Preferences>Reporting>Overlay Settings allows you to choose the default columns in 
your reports so that you can include only those demographics that are of interest to you. 

o The Aggregation Method window used to choose demographic fields has been redesigned 
to be easier-to-use. 

• The Tools>Routing & Directions>Distance and Travel Time Tables>Matrix>Open in Excel 
option freezes the first column and the first row in the Excel report. 

• The formatting on a column is preserved when you create a report, ensuring that fields such as 
income are displayed with the currency symbol, decimal places, etc. 

• The images and columns fit to the page dimensions when you create a report, ensuring that there 
are no overruns. 

• The column names are shown on every page when you create a report, ensuring that the report is 
easy to understand. 
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Imagery Improvements 
Accessing, creating, and visualizing image layers is a core feature of Maptitude and now imagery layers 
draw faster and with better resolution.  

New Documentation 
Maptitude continues to provide numerous ways to get you started with the software. There is a brand-
new online Learning Portal. New and revised tutorials are incorporated into the Maptitude Help.  

In addition, a variety of comprehensive learning materials (including videos and live or pre-recorded 
training webinars) are available on the Caliper Corporation website. The training videos run in all 
browsers, with playback settings, as YouTube videos. 

The Maptitude Help (Help > Maptitude Help) has been redesigned to be viewed within a web browser 
with a responsive interface.  

Maptitude 2019 includes a Windows Microsoft Office style question mark icon on most windows. Clicking 
this will take you to the relevant section of the Help. You can also hover over any menu item and click F1 
to access the updated Help. 

System and Interface 
Maptitude 2019 supports the latest Windows operating systems, file types, and common design 
elements. Maptitude 2019: 

• Includes installation changes that:  
o Provide for a more robust installer 
o Improve the Activation Wizard instructions and wording, avoiding ambiguities 
o Greatly reduce the need to reactivate the software 

• Includes several new and redesigned menus, buttons, graphics, icons, and toolbars that make tools 
and files more distinguishable, familiar, and accessible 

• Provides improved usability features:  
o Default folders 

 Remember the last folder you used when saving or opening a file, similar to Microsoft 
Office applications 

o Quick Start Window 
 Is replaced with a Home window that lists your most recently used files, the workspace file 

name, and lists clear choices on how to create a map or open a file, similar to Microsoft 
Office applications 

Workspaces 
Workspaces have been redesigned for Maptitude 2019. 

Workspaces:  
• Are now the primary document type used by Maptitude 2019 
• Can be saved as a Compressed Workspace (*.WRKZ) 
• Can be saved as an Uncompressed Workspace (*.WRK) 
• Support auto-saving in case you lose your work or forget to save it 

https://www.caliper.com/learning/
https://www.caliper.com/maptitude/mapping-software-video-tutorials.htm
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• Support file locking, similar to Microsoft Office applications, ensuring that work is not accidentally 
overwritten by other users, while letting you know who has the workspace open 

• Are more robust with better handling of missing or deleted files 
• Can be larger than 2 gigabytes in size 
• Can be merged by simply opening workspaces one after the other 
• Can contain a wide variety of information, such as drawing items, tables, and windows (e.g., 

map/3D/dataview/layout/chart windows) 
• Can be chosen via File > Save Workspace As, with your preference for Compressed or 

Uncompressed controlled via Edit > Preferences > System > Use compressed workspace  
• Support linking to table sources and auto-updating from these sources 

o If you choose Map>Update Linked Records any linked layers in a workspace map will be 
updated with the source table changes 

A Compressed Workspace (*.WRKZ): 
• Is a package of files “compressed” together, but it is different than an uncompressed workspace 

because it also embeds layers (*.DBD files) to simplify the sharing of maps 
• When opened, displays any information associated with the workspace as it was when the workspace 

was last saved 
• Allows for easy sharing of your work using a single file 
• Can be shared even if a linked data source is not available because the WRKZ contains a copy of the 

data that was obtained when the data was added to the workspace 
o Uncompressed (*.WRK) workspaces are unchanged. If you want to share your uncompressed 

workspace you will need to send the Maptitude workspace (*.WRK) file and any geographic 
(*.DBD) layers and tables. 

New File Import Support 
• MapPoint (.PTM, .EST, .AXE) shapes/lines/text as drawing items 
• Esri File Geodatabase (*.GDB) when ArcGIS is installed 
• Esri ArcSDE File Geodatabase (*.SDE) when ArcGIS is installed 
• Esri Arc ASCII Grid (*.ASC, *.ADF) 
• Microsoft Excel 2019 (and earlier versions) even when Office 2019 is not installed 

New File Export Support 
• Esri File Geodatabase (*.GDB) when ArcGIS is installed 
• Esri Feature Class (*.GDB) when ArcGIS is installed 
• Microsoft Excel 2019 (and earlier versions) even when Office 2019 is not installed 

New Native File Support 
• Caliper Compressed Workspace (*.WRKZ) 
• Esri File Geodatabase (*.GDB) when ArcGIS is installed 
• Esri ArcSDE File Geodatabase (*.SDE) when ArcGIS is installed 
• Microsoft Access and Excel 2019 (and earlier versions) even when Office 2019 is not installed 
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Geographic Information System Developer’s Kit (GISDK) 
APIs 
The GISDK .NET APIs make it easy to add mapping functionality to any Windows desktop application 
written in C# or any other .NET programming language.   

Code examples are here: http://www.caliper.com/Maptitude/extending-maptitude-in-dot-net.htm    

There is an additional User Guide for the Routing and Directions API that has been updated for 
Maptitude 2019, and you can contact Caliper Sales if you would like a copy.  

One highlight of the API changes: 

• The Caliper GISDK VSIX file is a software add-on created for Microsoft Visual Studio (a software 
development IDE for Windows) that extends the functionality of the Visual Studio software and: 

o Can be used with Visual Studio or the free Visual Studio Code Editor 
o Can be downloaded here: 

https://marketplace.visualstudio.com/items?itemName=Caliper.gisdk 
o Parses and colorizes GISDK-related files (such as .RSC files) 
o Provides code snippets for GISDK macros and functions 
o Provides a Code Outline/Goto Symbol for GISDK macro functions 
o Provides a Goto Definition for GISDK macro functions 
o Provides Code Completion suggestions for GISDK keywords 

GISDK Functions 
Please see the “Listing of GISDK Functions” topic in the Online Help to view a full list of GISDK functions 
that were added, changed, or replaced in Maptitude 2019.  

One highlight of the GISDK changes: 

• The Create-A-Map-Wizard “Link Data” tool and the Map > Update Linked Records tool can be 
called from the GISDK. This allows developers to refresh map layers and joins with updated data from 
sources such as SQL Server and Excel. 

o Calling JoinViews() with the "JoinLinkedString" sets a joined view to be linked. 
o Calling SetDBLinkedData() sets a layer (*.DBD) to be linked. 
o Calling RunMacro(Update Linked Records") performs an "Update Linked Records" on the 

layers and joins in a map. 

About Caliper  
Caliper Corporation develops state-of-the-art Geographic Information System (GIS) software. With 
a focus on usability, Maptitude is designed to be the most cost-effective professional mapping 
software product on the market. Maptitude enables organizations to leverage their location-based 
data to improve decision making and planning while minimizing expenditure through 
competitively priced solutions. 

Caliper is a privately held corporation and is a leading developer of mapping, 
redistricting, transportation, and GIS software. 

http://www.caliper.com/Maptitude/extending-maptitude-in-dot-net.htm
mailto:sales@caliper.com?subject=Request%20for%20Routing%20and%20Directions%20Network%20API
https://marketplace.visualstudio.com/items?itemName=Caliper.gisdk
http://www.mappingsoftware.com/
http://www.caliper.com/Maptitude/GIS_Software/Default.htm
http://www.caliper.com/Maptitude/mappingsoftware.htm
http://www.caliper.com/maptitude/MappingSoftware.htm
http://www.caliper.com/maptitude/MappingSoftware.htm
http://www.caliper.com/MapSoftware.htm
http://www.caliper.com/mtredist.htm
http://www.caliper.com/tcovu.htm
http://www.caliper.com/Maptitude/GIS_Software/Default.htm
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